CDN Degraded Performance
Incident Report for Beefree SDK
Resolved
We no longer see our CDN URL listed in popular ad blockers, and we confirmed that most customers no longer experience issues with images. There’s a small chance that some corporate filters or niche ad blockers may still temporarily block images until the fix propagates. In the unlikely case that you’re still experiencing issues, please reach out to our support team and we’ll investigate.
Posted Dec 05, 2024 - 06:47 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 04, 2024 - 10:18 PST
Monitoring
The issues affecting content visibility are steadily improving. The feeds that impact various blocklists are updating, and we anticipate a return to normal by tomorrow morning UTC. However, some residual effects, such as browser ad blockers, are still flagging content, and may persist temporarily. While significant progress has been made, we recommend checking this status page to stay updated on ongoing monitoring. Thank you for your patience as we continue to address this issue.
Posted Dec 04, 2024 - 09:11 PST
Investigating
We are investigating an issue where some images hosted on our CDN are not displaying for users due to a temporary listing of our CDN URLs on a spam blacklist. This affects users with specific ad blockers or antivirus settings, causing images to be invisible in libraries, designs, and landing pages. The delisting request has been approved, but it may take time for the update to propagate. Our team is actively monitoring the situation, reviewing systems to address vulnerabilities, and exploring solutions to prevent recurrence. For now, affected users can try disabling ad blockers or whitelisting our CDN.
Posted Dec 04, 2024 - 07:45 PST
This incident affected: Third-party components (AWS cloudFront).